YetAnotherForum
Welcome Guest Search | Active Topics | Log In | Register

My problem, please help
tuongericdoan
#1 Posted : Wednesday, December 20, 2017 2:03:28 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 12/16/2017(UTC)
Posts: 1

Thanks: 0 times
Was thanked: 0 time(s) in 0 post(s)
is there anyone successfully build or test the sqplus on x64?


I'm tring to build , but sqplus give me so many errors.





and, SQUIRREL2_1_1_sqplus_snapshot_20071014 seems to have some problem with unit test, the unit test report 10/18 failed with these config


#define SQ_USE_CLASS_INHERITANCE
#define SQ_SUPPORT_INSTANCE_TYPE_INFO
#define SQPLUS_CONST_OPT
#define SQPLUS_SMARTPOINTER_OPT
#define SQPLUS_OVERLOAD_OPT
#define SQPLUS_SUPPORT_STD_STRING
//#define SQPLUS_SUPPORT_SQ_STD_STRING
#define SQPLUS_SUPPORT_NULL_INSTANCES
#define SQPLUS_DISABLE_COPY_INSTANCES
#define SQPLUS_ENABLE_AUTO_TYPEMASK
#define SQPLUS_ENABLE_TYPEOF
#define SQ_SKIP_ARG_ASSERT


if I use these config, then the unit test seems fine with 18 success


#define SQ_USE_CLASS_INHERITANCE
#define SQ_SUPPORT_INSTANCE_TYPE_INFO
#define SQPLUS_CONST_OPT
//#define SQPLUS_SMARTPOINTER_OPT
#define SQPLUS_OVERLOAD_OPT
#define SQPLUS_SUPPORT_STD_STRING
//#define SQPLUS_SUPPORT_SQ_STD_STRING
//#define SQPLUS_SUPPORT_NULL_INSTANCES
//#define SQPLUS_DISABLE_COPY_INSTANCES
//#define SQPLUS_ENABLE_AUTO_TYPEMASK
#define SQPLUS_ENABLE_TYPEOF
#define SQ_SKIP_ARG_ASSERT


any suggestions?
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Clean Slate theme by Jaben Cargman (Tiny Gecko)
Powered by YAF 1.9.4 | YAF © 2003-2010, Yet Another Forum.NET
This page was generated in 0.080 seconds.